Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Log In

A valid email is required.
Password is required.
Site Notices
6/21/2017 8:25:40 PM
Posted: 11/27/2001 7:11:11 PM EDT
My cable internet provider is switching over to DHCP. Right now I have a static IP. In my TCP/IP settings I will have to provide a DHCP client ID number. I don't see anywhere to provide this number for my Linksys router. If I can't input this in my router info I will lose my firewall. Does anyone know what I can do to keep the router in the loop?
Link Posted: 11/27/2001 7:19:31 PM EDT
It sounds like you need to give them the MAC address for your router. There are some ISPs that require a MAC address to get an IP. Unless you meen they will be using PPPoE or PPPoA? In which case the Linksys will support this, although firmware is probably going to need to be updated depending on your providor.
Link Posted: 11/27/2001 7:21:18 PM EDT
Link Posted: 11/27/2001 7:29:05 PM EDT
No, it's a Mac.
Link Posted: 11/27/2001 7:44:06 PM EDT
You had this up and running allready correct? If thats the case you shouldn't have to make any changes to the LAN side of your Linksys. If you can bring up the config page (192.168.1.1 ) then your LAN side is ok.
Link Posted: 11/27/2001 7:45:34 PM EDT
The way I'm currently set up is this: The IP specified in my TCP/IP control panel is the router IP. The WAN IP specified in the router is the one assigned by my ISP. I know I can set the router up for DHCP but I think the holdup will be the client ID. I don;t think I can specify a client ID to the router.
Link Posted: 11/27/2001 7:50:39 PM EDT
Originally Posted By Bob243: You had this up and running allready correct? If thats the case you shouldn't have to make any changes to the LAN side of your Linksys. If you can bring up the config page (192.168.1.1 ) then your LAN side is ok.
View Quote
I'm not too bright when it comes to network stuff so bear with me. This will have to be changed by Nov. 30. So if I change my settings to "configure using DHCP server" and specify my client ID in TCP/IP I should be fine? The thing is that I can't set my IP within TCP/IP as the routers IP (which is the way it is now with a static IP). Will this not cause problems? I would think that in this situation the router will be out of the loop.
Link Posted: 11/27/2001 7:50:53 PM EDT
Link Posted: 11/27/2001 7:54:36 PM EDT
My ISP tells me that I will have to use the client ID to connect.
Link Posted: 11/27/2001 8:00:06 PM EDT
[Last Edit: 11/27/2001 7:53:35 PM EDT by Gloftoe]
Link Posted: 11/27/2001 8:01:51 PM EDT
I had the same question from my ISP. What they wanted was the MAC address of the Linksys. I have the BEFSR41. To find the MAC address open a web browser and view the admin page of the router. On the "Setup" page, there should be a "WAN IP Address" line. In parens is the WAN-side "MAC Address". Select "Obtain an IP Address Automatically". You'll probably have to put in the "Subnet Mask" value, which your ISP should give you.
Link Posted: 11/27/2001 8:22:31 PM EDT
No no no.... here is the deal... Your "client ID" is simply the NAME of the client. They provided this to you when you got your service. @home uses something like C3238782d with the name beginning in "C" and then a numeric string ending in a letter. The reason they do this is to only allow registered users to gain a DHCP IP address via a BOOTP host table they keep in their DHCP server. Therefore, even though you are utilizing "DHCP" from them, they still always assign you the same IP address from their registered host table. Your Linksys router can easily support this. Simply got to the main web configuration page, and under "Host Name" type in your "client ID" provided to you from your ISP. This all has NOTHING to do with how your LAN side (your PC) is configured... Only the WAN side. Any questions, shoot me an email.
Link Posted: 11/27/2001 8:45:29 PM EDT
Thanks guys, I think FALARAK gave me the answer.
Link Posted: 11/27/2001 8:48:07 PM EDT
Your "client ID" is simply the NAME of the client. They provided this to you when you got your service. @home uses something like C3238782d with the name beginning in "C" and then a numeric string ending in a letter.
View Quote
I concur. If your ISP requires a "computer name" or "client ID" or whichever terminology they're using, that has to be entered on your computer somewhere. I'm not as familiar where it's entered on the Macintosh, but it's a "name" they assign to you. Just take that name and type it in on the Linksys page where it says "Host Name." On my friend's @home setup, they gave her a "cx23423423" type number and "Workgroup" was "@home". So we copied the "cx" number to the "Host Name" box on the Linksys, then put "@home" in the Domain Name...[i]voila![/i] And you can always manually reset the router using the button on the front...
Link Posted: 11/27/2001 8:52:00 PM EDT
It's @Home service through Charter cable. Charter is taking over since @Home is going under. I was never given a client ID before. I was assigned a static IP.
Link Posted: 11/27/2001 9:45:17 PM EDT
[Last Edit: 11/27/2001 9:39:24 PM EDT by bunghole]
I can't get this shit to work! Here is a screen cap of my TCP/IP settings and my router settings. I replaced the client ID numbers with stars for obvious reasons. I am assigned an IP address when the client ID is entered in TCP. The router settings seem to work no matter what. The problem is when I change the Ethernet connection from manually configured to DHCP. The TCP/IP settings are set according to the ISPs instructions. [img]http://members-http-1.rwc1.sfba.home.net/jeff.hoeft/pics/TCPIP.jpg[/img] [img]http://members-http-1.rwc1.sfba.home.net/jeff.hoeft/pics/Router.jpg[/img]
Link Posted: 11/27/2001 11:09:40 PM EDT
Link Posted: 11/28/2001 12:57:09 AM EDT
It bothers me that that WAN MAC address field is blank on the LinkSys setup page. Mine is not. Did you click over to the LinkSys DHCP page and enable DHCP server? If you configured your Mac to be a DHCP client, then you have to configure the LAN side of the LinkSys to act as a DHCP server. The WAN side of the LinkSys acts as a DHCP client to your cable provider.
Link Posted: 11/28/2001 8:11:17 AM EDT
I erased the MAC address. Kinda like what people do with serial numbers, call me paranoid. I fgured out the problem. I enabled DHCP in the router but I had the starting IP set as the routers IP. I changed the last digit from 1 to 100. Now it works. Thanks for the help everyone.
Link Posted: 11/28/2001 8:51:53 AM EDT
Doesn't Linksys have 24X7 tech support? You could try calling them and have them walk you through it. Also, your ISP should be pretty familiar with the proper setup of home routers as well. They should be able to help out too. I'm sure you pay good money for your broadband connection, make them work for it. I've got mine hooked up to att/@home and all the router seemed to need from me was the "host name". The computer is set to get IP address automatically. I don't know squat about computers, I just get the tech support guys on the phone and set it up how they tell me.
Link Posted: 11/28/2001 9:28:05 AM EDT
Don't know about other ISP's but here is the proper procedure for EARTHLINK CUSTO/S TCP/IP Settings: The TCP/IP Control Panel will use the following settings • Connect via: Ethernet • Configure: [B]Manually[/B] • IP Address: 192.0.0.1 • Subnet Mask: 255.255.255.0 • Router Address: 192.0.0.2 • Name Server Address: 207.217.126.81 (ELNK) or 207.69.188.185 (MSPG) • Name Server Address: 207.217.77.82 (ELNK) or 207.69.188.186 (MSPG) • Name Server Address: 207.217.120.83 (ELNK) or 207.69.188.187 (MSPG) • Additional Search domains: earthlink.net or mindspring.com
Link Posted: 11/28/2001 2:05:27 PM EDT
bunghole, If the screen capture you're showing me is correct, change your Mac TCP/IP configure bar from using DHCP server to a specific IP address. Next, set your IP address to 192.168.1.2 Subnet mask to 255.255.255.0 Router IP to 192.168.1.1 That should be all you need to do. Your linksys is configured correctly already. If you still have problems please feel free to send me an email.
Top Top