Warning

 

Close

Confirm Action

Are you sure you wish to do this?

Confirm Cancel
Member Login

Log In

A valid email is required.
Password is required.
Site Notices
3/20/2017 5:03:23 PM
Posted: 6/16/2001 5:25:02 PM EDT
Just got a pre ban this morning. Took it to the range today and had problems with it ejecting rounds. About every 3rd one would hang in half in and out of the ejection port. I noticed also that the brass was ejecting forward and right instead of to the right rear also. Some of the brass that did eject only went about 2 foot also. Any ideas? Maybe a weak spring? Aviator [img]www.dredgeearthfirst.com/aviator.gif[/img]
Link Posted: 6/16/2001 5:33:45 PM EDT
Check the ejector spring. I had similar problem on my bush. Changed the spring and has been super reliable since then. Or it could be the ammo. What is the ammo you were using to test the AR?
Link Posted: 6/16/2001 5:59:52 PM EDT
[Last Edit: 6/16/2001 7:08:47 PM EDT by Oslow]
I just went through this scenario. Make sure the ejector is coming all the way out. You can hook an empty case under the extractor and work the ejector. Lube it up good. That may fix it. Disassemble the bolt, ejector and extractor. Make sure all are clean with no brass slivers in the works. Lube, re-assemble and try it out. If that doesn't do it, you need some new extractor and ejector parts. Edited cause I said to [b]lub[/b] something. I don't want to get in trouble for talking dirty. [:X*]
Link Posted: 6/16/2001 6:03:23 PM EDT
Am working on it now. Thanks guys. I was Using Both British Army (150 rd battle packs) and American Eagle (by Federal). It did seem to happen more often with the Federal. Aviator
Link Posted: 6/16/2001 6:17:44 PM EDT
I had no problem with the Eagle today.
Link Posted: 6/16/2001 7:37:40 PM EDT
I had an ejection problem with a really cherry Steyr kit from A&D Global (remember how good the kits were from them). I fooled with that rifle for over a year trying to fix it. I know, ignorant me. Be that as it may, I finally swapped extractors with another rifle and that cured the problem. The rifle was practically new and all I can say the extractor was some how out of spec. It would do fine some times, then every 3rd or 4th round would fail to eject, leaving a case in the receiver or half way out of the receiver.
Link Posted: 6/16/2001 7:43:50 PM EDT
While cleaning it, I noticed a bunch of white crap on a lot of the internal parts (springs and such). I cleaned it all off, and looks good to me now. The whatchamacallit (little steel thingy that pops the round out) springs out a lot better now. I think it may have been some kind of grease I did not get cleaned out of it when I cleaned it before I fired (was in a hurry and just did a general going over. Anyways. I'll try it again tomorrow and hopefully it will work better. BTW nice deal on the Pre Ban, $545.00 It was one of those Oly Arms ones that were made in 91 with TBOR (The Bill of Rights) SNs that were made of some kind of crappy coppery alloy. They were all recalled and Oly recently destroyed them, and remanufactured them as forged lowers. So it is basicly a pre ban that was just made. Aviator
Top Top