AR15.Com Archives
 Razorback..
jestertoo  [Team Member]
7/10/2011 1:58:51 PM
I got mine 2nd hand this week from another member. Timed the sear trip yesterday.. Had to take .050 off of it to get the .020 recommended gap.
Mounted up the comp ml2 on the Larue high mount along with the grip pod.
Manually cycles the dummy rounds great..

Apologies for the messy bench.
Paid Advertisement
--
raysheen  [Team Member]
7/10/2011 2:04:59 PM
Originally Posted By jestertoo:
I got mine 2nd hand this week from another member. Timed the sear trip yesterday.. Had to take .050 off of it to get the .020 recommended gap.
Mounted up the comp ml2 on the Larue high mount along with the grip pod.
Manually cycles the dummy rounds great..

Apologies for the messy bench.
http://www.frenzy.cc/~jester/pics/gun/RB-1.jpg


I really want one of those!
...and that's exactly what a bench in use is supposed to look like!
Shermantor-AR15  [Member]
7/10/2011 5:03:52 PM
I bought a new RB and received it the first week of June, Been out to the range about 6-7 times, it hasn't ran well at all even in Semi. You can read my threads on the Lakeside forums.

Basically I have been frustrated from the start with this upper, before I could even mount it on my lower I had to file out and enlarge the front pivot pin hole of the upper. I mean it wouldn't fit my OA PAWS M16 lower, a semi OA lower, or even a semi LMT lower. First range trip out, wouldn't even load any of the Aguila SuperMax ammo I had, turned out those rounds are too short. So I ordered the recommended CCI Blazers, but then ran into more problems, failure to feed with the rounds turning to the side after being pulled from the belt. Was told it was the extractor, and it wasn't aligned correctly etc... Now I'm being told it is probably the leaf spring which when I bend it back into the correct position, it would work for a few rounds before it went back to being out of tolerance. So I'll be mailing it back tomorrow to have that fixed.

The customer service has been good, if you send something back they will work on it and send it back quickly, I have sent back the upper minus the barrel, because the extractor was bent out of place, got it back still had problems, sent back just the extractor, he returned it with a new one, and then was told there might be another issue I mentioned above about the leaf spring, so it's going back again.

So to the OP, looking forward to hearing your range report on it, hope it works for you.
jrainw  [Member]
7/10/2011 6:43:17 PM
Mine is working great now that my belts are broken in. After about 800 rounds my barrel starts leading up pretty bad and it's like shooting a muzzle loader with a cloud of lead so thick I can't see the target. I'm going to try some copper plated bullets and see if they help with the lead problem. It"s a good problem.
rbtx  [Team Member]
7/12/2011 11:50:36 PM
Originally Posted By jrainw:
Mine is working great now that my belts are broken in. After about 800 rounds my barrel starts leading up pretty bad and it's like shooting a muzzle loader with a cloud of lead so thick I can't see the target. I'm going to try some copper plated bullets and see if they help with the lead problem. It"s a good problem.


Give the the Federal 550 from Walmart a try, mine runs great with it. In general it's much easier to run on hot ammo, especially while breaking in the belts. I'd really like to get it to run with subsonics but I'm not there yet. The lower I had already tuned for another .22 upper (slightly weaker hammer and trigger springs, verified there is minimal hammer dip when the auto sear trips).

Mine is shown a few times here, best at 2:03:

AAC Silencer Shoot
Mtnvalley3  [Team Member]
7/14/2011 12:15:37 AM
Originally Posted By Shermantor-AR15:

Basically I have been frustrated from the start with this upper, before I could even mount it on my lower I had to file out and enlarge the front pivot pin hole of the upper. I mean it wouldn't fit my OA PAWS M16 lower, a semi OA lower, or even a semi LMT lower.


I recently purchased a RB, haven't had time to shoot it yet...but had a very similar problem. Fortunately my dealer is a great 'smith, and he eliminated it being the hole after sizing it with a pin and then trying a few different lowers on it, all with same result. He wound up dremeling a small bit of metal from the upper right above the pin hole, and voila.

I believe that Eric does testfire everything before it goes out...but I suspect his test lower must be pretty worn at that spot for your upper and mine to fit his, but none other of several lowers tested. I'm hoping that the failure to even mount up out of the box is not an omen of things to come...

renraf  [Team Member]
7/14/2011 12:24:31 AM
Originally Posted By Shermantor-AR15:
I mean it wouldn't fit my OA PAWS M16 lower, a semi OA lower, or even a semi LMT lower.


For what it's worth my OA PAWS M16 has upper fit issues as well. I find that it's the billet uppers that seem to give me problems.
Paid Advertisement
--