AR15.Com Archives
 92 Chevy Oil Pressure Sending Unit ???'s
DPeacher  [Team Member]
8/17/2002 5:00:59 PM
It looks like the oil pressure sending unit on my 92 Chevy 1500 is going bad. When the engine is cool the pressure gauge on the dash delivers normal readings, but as the engine heats up the oil pressure gauge slowly drops from 45 psi to 15 psi at speed, and from 30 psi to 0 psi at idle. The engine does not overheat or make any noise to indicate inadequate lubrication. Now here is the question. [b]Where is the OPSU located on a 6 cylinder engine?[/b] I went to the auto parts store and picked up the part, and refered to my Haynes manual, but I can't find the darn thing. Any help would be appreciated! (Let's see how many "Should have bought a Ford/Dodge/Toyota" replies this generates.)
thedave1164  [Team Member]
8/17/2002 5:29:02 PM
I am assuming this is the 4.3L. If so check the top of the engine, back by the distributor. It would be on the block itself not the intake manifold. If it is not there, good luck....
SBR7_11  [Team Member]
8/17/2002 7:45:35 PM
[quote]Originally Posted By DPeacher: Any help would be appreciated! (Let's see how many "Should have bought a Ford/Dodge/Toyota" replies this generates.) [/quote] I can't let you down on this one; On Toyota 4 cyl trucks, it is on the right side of block adjacent to oil filter. On the V6, it it close to oil folter at left front corner of block, pointing upwards, and on the V8, it's on the oil filter housong-adapter at left front.
MickeyMouse  [Member]
8/17/2002 8:16:10 PM
Look at rear top of block. If no luck, look near oil filter. Good luck as some 4.3L around that time had bottom end problems, and THAT is a big deal!!
DPeacher  [Team Member]
8/17/2002 11:57:51 PM
Thanks everyone! It is indeed located on the top rear of the block, just behind, under, and to the left of the distributor. Very well hidden. Oil pressure readings have returned to normal, and if this OPSU gets anywhere near the 198,563 miles the original did, I'll be very happy indeed! FYI......The Haynes manual describes the location as "above the oil filter", so I was under the truck looking for it. I suppose the manual was "technically" correct but that was a poor description.
MickeyMouse  [Member]
8/18/2002 8:56:02 AM
Glad your problem was simple!! Haynes and Chillton are wrong more than right. If you want a GOOD manual, contact Helm and get the real thing - a GM shop manual! A lot of times they can be found used at car shows too.
Neolock  [Member]
8/18/2002 2:10:03 PM
Damn mine is doing the same thing. At 175K miles I just assumed the when the oil heated up the it lost PSI because of worn bearings.
DPeacher  [Team Member]
8/18/2002 2:34:03 PM
Neolock, It is an easy and cheap issue to resolve. Advance Auto Parts has them for less then $25 out the door here in Austin. Remove the air filter housing. Label the sparkplug wires and disconnect them from the distributor. Remove the distributor cap. Disconnect the electrical connections. Unscrew the old OPSU. Reassemble in reverse order. I imagine this is much cheaper and easier then replacing the oil pump. I found that mine had leaked oil all the way through the OPSU to the electrical connector.